Incorrect Click Metrics for June 24th 2018
Incident Report for Bitly
Resolved
All metrics are now updated.
Posted 22 days ago. Jun 29, 2018 - 16:39 EDT
Monitoring
We have identified an issue impacting users where click metrics for the date of June 24th will be incorrect. The metrics will be restored by 2018-06-27 00:00 UTC.
Posted 26 days ago. Jun 26, 2018 - 00:37 EDT
This incident affected: Metrics.