Bitly Website
Incident Report for Bitly
Resolved
All systems are operating normally.
Posted about 2 months ago. Oct 29, 2017 - 11:59 EDT
Identified
An issue with our front-end website (Bitly.com) and some portions of our Web Application Interface has been discovered. Users may experience slower page loads until the issue is resolved.
Posted about 2 months ago. Oct 29, 2017 - 11:51 EDT