Delayed Metrics
Incident Report for Bitly
Resolved
All Bitly services are operating normally.
Posted 4 months ago. Jul 10, 2017 - 16:48 EDT
Update
We are continuing to work on restoring the audience benchmarking metrics.
Posted 4 months ago. Jul 10, 2017 - 14:39 EDT
Identified
We have identified a delay in the display of click metrics impacting some users.
Posted 4 months ago. Jul 10, 2017 - 10:10 EDT