Bitlink Creation Problems
Incident Report for Bitly
Resolved
All Bitlink creation services via our website have been restored.
Posted 12 months ago. Oct 26, 2016 - 13:26 EDT
Identified
We have identified failures in creating Bitlinks from our website. We are actively working to repair this issue.
Posted 12 months ago. Oct 26, 2016 - 13:23 EDT