Sign in with Twitter Down
Incident Report for Bitly
Resolved
We have fixed the issue and signing in with Twitter is operational again.
Posted 6 months ago. Jun 12, 2018 - 19:56 EDT
Identified
We have identified an issue signing in with Twitter and are working to resolve it.
Posted 6 months ago. Jun 12, 2018 - 19:35 EDT