Reporting Delay
Incident Report for Bitly
Resolved
This incident has been resolved.
Posted 11 months ago. May 23, 2017 - 20:07 EDT
Identified
Metrics for clicks that occurred on May 21st are currently delayed, and will be available after May 23rd 8pm EST. All other metrics are available.
Posted 11 months ago. May 22, 2017 - 20:11 EDT