Incorrect Click Metrics for August 18th 2018
Incident Report for Bitly
Resolved
This incident has been resolved.
Posted about 1 month ago. Aug 20, 2018 - 20:29 EDT
Identified
We have identified an issue impacting users where click metrics for the date of August 18th will be incorrect.
Posted about 1 month ago. Aug 19, 2018 - 20:06 EDT
This incident affected: Metrics.