General Issues
Incident Report for Bitly
Resolved
This incident has been resolved.
Posted about 1 month ago. Aug 05, 2019 - 09:39 EDT
Investigating
Hi community. We’re seeing early indications of issues impacting loading your Bitlinks page history on the website for some of our user base. We’re looking into this now and will share an update soon.
Posted about 1 month ago. Aug 05, 2019 - 09:09 EDT
This incident affected: Website (Bitly.com).