Issues with completing account sign up
Incident Report for Bitly
Resolved
This incident has been resolved.
Posted Dec 01, 2023 - 21:21 EST
Monitoring
Good news, community: if you were impacted by the earlier account sign up issue, you should now be able to access our services without any problems. Thanks for bearing with us! For more info on this incident please see our status page: status.bitly.com
Posted Dec 01, 2023 - 20:58 EST
Investigating
Hi community. We’re seeing indications of errors affecting users attempting to sign up for an account . We’re looking into this now and will share an update within 30 minutes.
Posted Dec 01, 2023 - 20:33 EST
This incident affected: Website (Bitly.com).