Intermitent Issues with Billing Related Actions
Incident Report for Bitly
Resolved
This incident has been resolved.
Posted Sep 04, 2024 - 16:02 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 04, 2024 - 15:46 EDT
Identified
We are currently experiencing issues with our 3rd party billing provider. This is intermittently affecting various billing related actions (upgrading to paid plans, retrieving billing information, etc). The provider has acknowledged the incident and the cause is currently under investigation. We are monitoring the situation closely and will share an update as soon as we know more!
Posted Sep 04, 2024 - 14:42 EDT
This incident affected: Website (Bitly.com).