Bitly is experiencing issues with email related services
Incident Report for Bitly
Resolved
The third party has implemented a fix and all systems are once again operational
Posted Sep 22, 2022 - 22:20 EDT
Update
Update: the third party provider is currently investigating the issue
Posted Sep 22, 2022 - 21:12 EDT
Investigating
We have identified an issue with a third party provider that affects email related services. You may experience errors or delays receiving emails (such as password reset emails) or adding or inviting email addresses to accounts.
Posted Sep 22, 2022 - 20:25 EDT
This incident affected: Website (Bitly.com).