3rd Party Billing Provider Outage
Incident Report for Bitly
Resolved
This incident has been resolved!
Posted Apr 17, 2023 - 12:29 EDT
Monitoring
The 3rd party billing provider Bitly was experiencing issues with has implemented a fix and everything appears to be operational. We will continue to monitor the situation to confirm that no new issues arise.
Posted Apr 17, 2023 - 12:01 EDT
Update
Bitly is currently experiencing some issues with our 3rd party billing provider. They are aware of the outage and are working on this with the highest priority.
Posted Apr 17, 2023 - 11:15 EDT
Identified
Hi community. We are currently experiencing an issue with our 3rd party billing provider which is preventing upgrades (and downgrades) to paid Bitly plans, in addition to making billing information such as invoices unavailable. We are monitoring the situation and will share an update within 30 minutes.
Posted Apr 17, 2023 - 10:38 EDT
This incident affected: Website (Bitly.com).