Issues with Billing Related Actions
Incident Report for Bitly
Resolved
The incident with our 3rd party billing provider has been resolved and we've seen full recovery. We appreciate your patience!
Posted Nov 28, 2024 - 05:28 EST
Monitoring
We are currently observing recovery from a 3rd party software outages that was was affecting various billing related actions (upgrading to paid plans, retrieving billing information, etc). We are continuing to monitor the situation closely!
Posted Nov 28, 2024 - 05:20 EST
Update
We are currently experiencing issues with our 3rd party billing provider. This is affecting various billing related actions (upgrading to paid plans, retrieving billing information, etc). The provider has identified the issue and is currently implementing a fix. We are monitoring the situation closely and will share an update as soon as we know more.
Posted Nov 28, 2024 - 05:09 EST
Update
We are currently experiencing issues with our 3rd party billing provider. This is affecting various billing related actions (upgrading to paid plans, retrieving billing information, etc). The provider has acknowledged the incident and is currently investigating. We are monitoring the situation closely and will share an update as soon as we know more.
Posted Nov 28, 2024 - 04:38 EST
Identified
We are currently experiencing issues with our 3rd party billing provider. This is affecting various billing related actions (upgrading to paid plans, retrieving billing information, etc). We are monitoring the situation closely and will share an update as soon as we know more.
Posted Nov 28, 2024 - 04:16 EST
This incident affected: Website (Bitly.com).