bitly.com is not loading for logged in users
Incident Report for Bitly
Resolved
This incident has been resolved.
Posted 4 months ago. Apr 23, 2019 - 13:07 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 4 months ago. Apr 23, 2019 - 12:20 EDT
Investigating
We are currently investigating this issue.
Posted 4 months ago. Apr 23, 2019 - 11:49 EDT
This incident affected: Website (Bitly.com).