Website and Metrics Outage
Incident Report for Bitly
Resolved
This incident has been resolved and all services are operational!
Posted 3 months ago. Jun 03, 2019 - 14:03 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 3 months ago. Jun 03, 2019 - 13:19 EDT
Investigating
We are currently investigating reports of issues with the website and metrics impacting much of our user base.
Posted 3 months ago. Jun 03, 2019 - 12:56 EDT
This incident affected: Website (Bitly.com) and Metrics.