Issues with uploaded Images

Incident Report for Bitly

Postmortem

From 16:41Z - 23:56Z operations on and access to user uploaded images failed. This affected user ability to add new images to QR codes and Pages, and affected display of user uploaded images on Page buttons and backgrounds.

The root cause was human error by our service provider during the application of a policy change. A restriction intended for one object incorrectly applied at the bucket level.

We understand the significant impact this has had and we are taking steps with our service provider to prevent this from happening again.

Posted Apr 08, 2025 - 14:13 EDT

Resolved

The issue has been resolved, and all services appear to be operating as expected.
Posted Apr 07, 2025 - 20:58 EDT

Monitoring

We are seeing improvement and will continue to monitor the situation.
Posted Apr 07, 2025 - 20:01 EDT

Identified

We have identified the issue and are working to resolve it. Images are unable to be retrieved or uploaded. This may affect QR Code logos and Bitly Pages with images.
Posted Apr 07, 2025 - 13:52 EDT

Update

We are continuing to investigate, this is also affecting uploading images.
Posted Apr 07, 2025 - 13:33 EDT

Investigating

We are currently investigating an issue preventing uploaded images to be fetched. This could be affecting Link in Bios and QR codes.
Posted Apr 07, 2025 - 13:24 EDT
This incident affected: Bitly Pages.