Bitly is experiencing issues with email related services
Incident Report for Bitly
Resolved
This incident has been resolved.
Posted Jun 09, 2022 - 09:56 EDT
Update
We are continuing to work on a fix for this issue.
Posted Jun 09, 2022 - 09:14 EDT
Update
We are continuing to work on a fix for this issue.
Posted Jun 09, 2022 - 09:10 EDT
Identified
We have identified an issue with email related services, so you may experience errors or delays receiving emails (such as password reset emails) or adding or inviting email addresses to accounts.
Posted Jun 09, 2022 - 09:10 EDT
This incident affected: Website (Bitly.com).