Provider outage affecting [product functonality]

Incident Report for Bitly

Resolved

The outage of our 3rd party provider that was blocking new user sign ups has been resolved.
Posted Sep 11, 2025 - 20:21 EDT

Monitoring

We are observing recovery of the 3rd party outage that was causing issues with new sign ups. We are continuing to monitor the situation to ensure that functionality has been fully restored.
Posted Sep 11, 2025 - 19:50 EDT

Identified

We have identified a 3rd party provider outage impacting our new user sign up functionality. Our on-call team is working with the provider to restore functionality for Bitly users. We will provide an update within 30 minutes.
Posted Sep 11, 2025 - 19:21 EDT
This incident affected: Website (Bitly.com).