Intermittent Issues with Billing Related Actions
Incident Report for Bitly
Resolved
This incident has been resolved - all billing/payment related functionality should be restored.
Posted Jul 09, 2024 - 14:16 EDT
Monitoring
The third party has implemented a fix and we are observing recovery on our end for our billing related actions. We will continue to monitor the results.
Posted Jul 09, 2024 - 13:49 EDT
Identified
We are currently experiencing issues with our 3rd party billing provider which are intermittently affecting various billing related actions (upgrading to paid plans, retrieving billing information, etc). The 3rd party has acknowledge the issue and is investigating a fix. We are monitoring the situation closely and will share an update as soon as we know more!
Posted Jul 09, 2024 - 13:11 EDT
This incident affected: Website (Bitly.com).