Partial Outage Impacting Pricing and Packaging

Incident Report for Bitly

Resolved

The issue has been identified and resolved. We will continue to monitor.
Posted Mar 16, 2026 - 16:20 EDT

Investigating

We are currently experiencing an issue with our 3rd party provider that is resulting in a partial degradation of services relating to pricing and packaging. We continue to monitor the situation.
Posted Mar 16, 2026 - 15:42 EDT
This incident affected: Website (Bitly.com).