Bitlink history outage
Incident Report for Bitly
Resolved
This incident has been resolved.
Posted 7 months ago. Feb 07, 2019 - 11:48 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 7 months ago. Feb 06, 2019 - 18:22 EST
Identified
Bitlink history is temporarily unavailable. We have identified the issue and are working to restore access.
Posted 7 months ago. Feb 06, 2019 - 18:09 EST
This incident affected: Website (Bitly.com).