Major Service Outage - API

Incident Report for Bitly

Postmortem

On 2025-05-13 We experienced an outage affecting the Bitly Public API from 18:12Z to 18:34Z. This affected the ability to use the Bitly site or create new links, but did not impact usage of any existing links.

The root cause was an error with a newly provisioned application secret which caused a fatal API service error that didn't fail our deployment pipeline.

Our monitoring systems detected the issue quickly and we successfully rolled back to restore services. We have since taken steps towards resolving root causes, including improving secrets validation and faster failure detection during service initialization.

Posted Jun 11, 2025 - 11:24 EDT

Resolved

This incident has been resolved.
Posted May 13, 2025 - 14:37 EDT

Identified

The issue has been identified and we are working to restore the service.
Posted May 13, 2025 - 14:34 EDT

Update

We are continuing to investigate this issue.
Posted May 13, 2025 - 14:30 EDT

Investigating

We are currently investigating reports of a major service outage impacting our public API. Our on-call team is working to identify and resolve this issue. We will provide an update within 30 minutes.
Posted May 13, 2025 - 14:30 EDT
This incident affected: Website (Bitly.com) and API.