Major Service Outage - Bitly.com Website Unavailable

Incident Report for Bitly

Resolved

The incident affecting availability of bitly.com has been resolved and the website is fully operational.
Posted Apr 25, 2026 - 19:10 EDT

Monitoring

We are seeing recovery from an issue that was affecting the availability of bitly.com. We will continue to monitor.
Posted Apr 25, 2026 - 19:06 EDT

Investigating

We are currently investigating reports of a major service outage impacting the Bitly website (bitly.com). Our on-call team is working to identify and resolve this issue. We will provide an update within 30 minutes.
Posted Apr 25, 2026 - 19:04 EDT
This incident affected: Website (Bitly.com).