Intermitent Issues with Billing Related Actions
Incident Report for Bitly
Resolved
This incident has been resolved.
Posted Jul 31, 2024 - 16:43 EDT
Update
Our 3rd party billing provider has implemented a fix and we are starting to see recovery in performance. We will continue to monitor the situation to ensure that the issues are resolved.
Posted Jul 31, 2024 - 16:31 EDT
Monitoring
Our billing provider has implemented a fix and we are seeing signs of recovery in billing related actions (upgrading to paid plans, retrieving billing information, etc).
Posted Jul 31, 2024 - 16:30 EDT
Update
Our 3rd party billing provider outage is ongoing and we are monitoring their updates closely. Billing related actions continue to be affected; we will share any updates as we know more.
Posted Jul 31, 2024 - 15:59 EDT
Identified
We are currently experiencing issues with our 3rd party billing provider. This is intermittently affecting various billing related actions (upgrading to paid plans, retrieving billing information, etc). The provider has acknowledged the incident and the cause is currently under investigation. We are monitoring the situation closely and will share an update as soon as we know more!
Posted Jul 31, 2024 - 15:05 EDT
Investigating
We are currently experiencing issues with our 3rd party billing provider. This is intermittently affecting various billing related actions (upgrading to paid plans, retrieving billing information, etc). We are monitoring the situation closely and will share an update as soon as we know more!
Posted Jul 31, 2024 - 14:54 EDT
This incident affected: Website (Bitly.com).