Intermitent Issues with Billing Related Actions
Incident Report for Bitly
Resolved
This incident has been resolved.
Posted Apr 01, 2024 - 09:52 EDT
Identified
We are currently experience issues with our 3rd party billing provider which is intermittently affecting various billing related actions (upgrading to paid plans, retrieving billing information, etc). The provider has acknowledged the incident and the cause is currently under investigation. We are monitoring the situation closely and will share an update as soon as we know more!
Posted Apr 01, 2024 - 06:28 EDT
This incident affected: Website (Bitly.com).