Incorrect Click Metrics for May 5th 2018
Incident Report for Bitly
Resolved
All click metric data for May 5th has been restored and systems are functioning normally.
Posted 5 months ago. May 08, 2018 - 20:37 EDT
Identified
We have identified an issue impacting users where click metrics for the date of May 5th will be incorrect. The metrics will be restored by 2018-05-09 00:00 UTC.
Posted 5 months ago. May 07, 2018 - 17:30 EDT