Incorrect Click Metrics for the 26th
Incident Report for Bitly
Resolved
All click metric data for April 26th has been restored and systems are functioning normally.
Posted about 2 months ago. May 02, 2018 - 20:31 EDT
Identified
We've identified an issue where some click metrics for the date of April 26th will be incorrect. The metrics will restored by 2018-05-03 00:00 UTC.
Posted about 2 months ago. May 01, 2018 - 11:21 EDT