Increased Link History Errors
Incident Report for Bitly
Resolved
The incident has been resolved and Link History is functioning normally again.
Posted 3 months ago. Aug 17, 2018 - 15:19 EDT
Investigating
We are currently experiencing increased load on the systems that power Link History. We are actively working to address the issue.
Posted 3 months ago. Aug 17, 2018 - 14:11 EDT