Comcast outage for some Bitly users.
Incident Report for Bitly
Resolved
All Bitly services are operating normally.
Posted 7 months ago. Mar 06, 2018 - 16:03 EST
Identified
We have detected that Comcast has blocked access to Bitly for some of its customers. We have engaged disaster recovery solutions to restore service to affected users until Comcast can unblock our services globally.
Posted 7 months ago. Mar 06, 2018 - 15:01 EST